Шаг 270 - Знакомимся с диаграммой

Цифры, цифрами, но смотреть на колонки цифр очень утомительно. Гораздо лучше смотреть на диаграмму. Тут все понятно. Одна колонка Выше, другая колонка ниже. В таблицу отчет можно встроить диаграмму. Создаем новый отчет. Вот код.

Процедура Сформировать()
	Т = СоздатьОбъект("Таблица");
  	Т.ВывестиСекцию("Секция_1");   	
	Т.ТолькоПросмотр(1);
	Т.Показать();
КонецПроцедуры

Теперь нужно поместить саму диаграмму на таблицу.

270_1.gif (17059 b)

Вот, диаграмма у нас в секции. Секция нам все равно нужна для вывода диаграммы на экран. Вот теперь будет один очень тонкий нюанс. Нам нужно устанавливать параметры диаграммы, такие как количество серий и сами данные. В свойствах текст нужно указать имя процедуры, которая будет вызвана и передать указатель на диаграмму.

270_2.gif (6166 b)

Обратите внимание, что я передаю объект Т, который был создан в коде ранее. Теперь в этой функции можно производить настройку диаграммы.

//*******************************************
Процедура Сформировать()
	Т = СоздатьОбъект("Таблица");
	Т.ВывестиСекцию("Секция_1");   	
	Т.ТолькоПросмотр(1);
	Т.Показать();
КонецПроцедуры


Процедура   ПостроитьДиаграмму(Диаграмма)
	Диаграмма.КоличествоСерий(1);
КонецПроцедуры

Запустим, посмотрим.

270_3.gif (2628 b)

Вроде как толку никакого. На самом деле толк есть. Видно, что процедура сработала. Иначе Вы увидели бы что-то в таком роде.

270_4.gif (6428 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.