Шаг 265 - Ведем оперативный учет

Итак, мы посмотрим как можно организовать учет аффинажа практически в полуавтоматическом режиме. Итак, мы периодически проплачиваем за аффинаж. Завод в ответ нам выставляет расшифровку о том, сколько он возьмет за каждую партию золота. Партий за месяц может быть много. Для учета сделаем регистр.

265_1.gif (1724 b)

Для заполнения регистра сделаем документ, в котором будет заполнять расшифровку, кому и за что.

265_2.gif (6978 b)

Теперь мы можем в любой момент получить отчет по измерениям, то есть выбрать на какую сумму мы покрыли расходы своих клиентов. Как писать данный код мы уже обсуждали.

Процедура Сформировать() 
	Перем Пр;
	Пр=0;
	Т=СоздатьОбъект("Таблица");
	Т.ВывестиСекцию("Секция_1"); 
	Рег1 = СоздатьОбъект("Регистр.УслугиАфинажа");
		    	 
	Если Кому.Выбран()=1 Тогда  
		Рег1.УстановитьФильтр(Кому);
	КонецЕсли;
		 		
	Рег1.ВыбратьДвижения(ДатаНач,ДатаКон);
		 
	Пока Рег1.ПолучитьДвижение() > 0 Цикл
		Т.ВывестиСекцию("Секция_2");
		Пр=Пр+Рег1.Сумма;
	КонецЦикла;  
	Т.ВывестиСекцию("Секция_3");  
	Т.ТолькоПросмотр(1);
	Т.Показать();
КонецПроцедуры

Вроде все нормально, только в счет фактуру сумму нужно в ручную заносить из отчета, не порядок.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.