Шаг 41 - Изучаем Счета – Количественный

Узнать является ли счет количественным можно и программным путем. Для этого есть атрибут Количественный.

Количественный
Признак ведения количественного учета.

Синтаксис:

Количественный

Англоязычный синоним:

IsAmount

Значение:
1 — количественный учет ведется по данному счету;
0 — количественный учет не ведется по данному счету;

Описание:
Атрибут содержит признак ведения количественного учета по счету. Изменение данного значения из языка следует производить только в особых случаях и с учетом всех особенностей настройки учета. После изменения настроек учета система может потребовать выполнить пересчет итогов.

Давайте им воспользуемся для вывода информации о счете. Для начала заведем переменную которая будет хранить результат.

Процедура Сформировать()  
Перем  ИнформацияКол; // Переменная всегда в начале

.......
КонецПроцедуры

А теперь, если атрибут Количественный, то присвоим ей Да, иначе Нет.

Процедура Сформировать()  
Перем  ИнформацияКол;
............
Т.ВывестиСекцию("Секция_1");   
     
    
    Если  ВыборСчета.Количественный = 1 Тогда
    	  ИнформацияКол="Да";
    Иначе	  
     	  ИнформацияКол="Нет";
    КонецЕсли; 

   Т.ВывестиСекцию("Секция_2");	  
   Т.ТолькоПросмотр(1);
   Т.Показать();
КонецПроцедуры

А в таблице просто отобразим эту переменную.

41_1.gif (3600 b)

Запускаем, чтобы убедиться, у меня в плане счетов 41 количественный, а 20 нет.

41_2.gif (6557 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.