Шаг 298 - Дальше и дальше

Дальше производятся практически одинаковые действия.

........
Если ТипЗначенияСтр(ДокументПоступления) = "Документ" Тогда
	ДокументаПоступленияДата = ДокументПоступления.ДатаДок;
	ДокументаПоступленияНомер = ДокументПоступления.НомерДок;
Иначе
	ДокументаПоступленияДата = "";
	ДокументаПоступленияНомер = "";
КонецЕсли;
Если ТипЗначенияСтр(ДокументВводаВЭксплуатацию) = "Документ" Тогда
	ДокументВводаВЭксплуатациюДата = ДокументВводаВЭксплуатацию.ДатаДок;
	ДокументВводаВЭксплуатациюНомер = ДокументВводаВЭксплуатацию.НомерДок;
Иначе
	Если ПустоеЗначение(ДатаВводаВЭксплуатацию) = 0 Тогда
		ДокументВводаВЭксплуатациюДата = ДатаВводаВЭксплуатацию;
	Иначе
		ДокументВводаВЭксплуатациюДата = "";
	КонецЕсли;
	ДокументВводаВЭксплуатациюНомер = "";
КонецЕсли;
Если ТипЗначенияСтр(ДокументВыбытия) = "Документ" Тогда
	ДокументВыбытияДата = ДокументВыбытия.ДатаДок;
	ДокументВыбытияНомер = ДокументВыбытия.НомерДок;
Иначе
	ДокументВыбытияДата = "";
	ДокументВыбытияНомер = "";
КонецЕсли;
.......

Мы получаем даты этих документов, но сначала проверяем, что получена именно ссылка на документ при помощи функции ТипЗначенияСтр.

ТипЗначенияСтр
Получить строковое обозначение типа данных.

Синтаксис:

ТипЗначенияСтр(<3начение>)

Англоязычный синоним:

ValueTypeStr

Параметры:
<3начение> Выражение, тип данныхзначения которого надо определить.

Возвращаемоезначение:
Функция возвращает строковое значение в русскоязычном или в англоязычном написании — в зависимости от текущей установки основного языка конфигурации:

Русскоязычное		Англоязычное		Описание
Неизвестный Объект		UnknownObject		неопределенный типданных;
Число			Number			числовой тип данных;
Строка			String			строковый тип данных;
Дата			Date			тип данных — дата;
Перечисление		Enum			агрегатный тип данных Перечисление;
Справочник		Reference			агрегатный тип данных Справочник;
Документ			Document			агрегатный тип данных Документ;
Регистр			Register			агрегатный тип данных Регистр;
Календарь			Calendar			агрегатный тип данных <Календарь>;
ВидРасчета		Calculation		агрегатный тип данных <ВидРасчета>;
ЖурналРасчетов		CalcJournal		агрегатный тип данных <ЖурналРасчетов>;
ПланСчетов		ChartOfAccounts		агрегатный тип данных <ПланСчетов>;
Счет			Account			агрегатный тип данных <Счет»,
Операция			Operation			агрегатный тип данных <Операция>;
КорректныеПроводки		CorrectEntries		агрегатный тип данных <КорректныеПроводки>;
БухгалтерскиеИтоги		BookkeepingTotals		агрегатный тип данных <БухгалтерскиеИтоги>;
Таблица			Table			агрегатный тип данных <Таблица>;
Текст			Text			агрегатный тип данных <Текст>;
Запрос			Query			агрегатный тип данных <Запрос>;
СписокЗначений		ValueList			агрегатный тип данных <СписокЗначений>;
ТаблицаЗначений		ValueTable		агрегатный тип данных <ТаблицаЗначений>;
Периодический		Рег1odic			агрегатный тип данных <Периодический>;
Картинка			Picture			агрегатный тип данных <Картинка>;
ГрупповойКонтекст		GroupContext		локальный контекст программногомодуля, передаваемый при помощи ключевого слова 
						Контекстили возвращаемый методомОткрытьПодбор;
OLE			OLE			OLE-объект;

Описание:
Функция ТипЗначенияСтр определяет, к какому типу данных принадлежит переданный параметр <3начение> и возвращает соответствующе строковое значение. Название агрегатного типа данных передается либо в русском либо в английском написании — в зависимости от текущей установки основного языка конфигурации.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.