Шаг 19 - Получаем бухгалтерские итоги

Для быстрого получения информации о состоянии счетов есть возможность использовать объект БухгалтерскиеИтоги. Используя этот объект можно быстро получить информации об итогах бухгалтерской деятельности с детальностью в месяц. Эти итоги поддерживает в актуальном состоянии. При детальности менее месяца нужно использовать запрос. Давайте попробуем воспользоваться этим объектом для того, чтобы получить итоги по счету, дополнив отчет карточки счета. Вот новый код модуля:

Процедура Сформировать() 
	Перем Т; 
	Перем Ит;
	Перем Заголовок;
	Перем Опер; 
	Перем ДебитовоеСальдо;
	Перем КредитовоеСальдо;
	Перем ДебитовоеСальдоКонец;
	Перем КредитовоеСальдоКонец; 
	Перем ДебитовыйОборот;
	Перем КредитовыйОборот;

	Если Счет.Выбран() = 0 Тогда
		Предупреждение("Не указан счет!");
		Возврат;
	КонецЕсли;
	Т = СоздатьОбъект("Таблица");
	Ит = СоздатьОбъект("БухгалтерскиеИтоги");
	Ит.ВыполнитьЗапрос(Дата1, Дата2, Счет,,,, "Проводка"); 
	Заголовок = "Карточка счета: "+Счет;
	Т.ВывестиСекцию("Секция_1"); 
	Ит.ВыбратьПериоды();
	Пока Ит.ПолучитьПериод() = 1 Цикл
		Опер = Ит.Операция;
		Т.ВывестиСекцию("Секция_2"); 
	КонецЦикла;

	Т.ВывестиСекцию("Секция_3"); 

	ДебитовоеСальдо=Ит.СНД(Счет);
	КредитовоеСальдо=Ит.СНК(Счет);
	ДебитовоеСальдоКонец=Ит.СКД(Счет);
	КредитовоеСальдоКонец=Ит.СКД(Счет);
	ДебитовыйОборот=Ит.ДО(Счет);
	КредитовыйОборот=Ит.КО(Счет);

	Т.ВывестиСекцию("Секция_4"); 
	Т.ВывестиСекцию("Секция_5");
	Т.ВывестиСекцию("Секция_6"); 
	Т.ВывестиСекцию("Секция_7");
	Т.ВывестиСекцию("Секция_8");
	Т.ТолькоПросмотр(1);
	Т.Показать();

КонецПроцедуры

А вот новая таблица:

19_1.gif (5092 b)

Результат построения отчета:

19_2.gif (2752 b)

Как видите очень быстро и просто строится отчет.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.