Шаг 17 - Делаем карточку счета

Итак, нам бы хотелось посмотреть, какие операции проводились с данным счетом. Создадим отчет с именем КарточкаСчета и диалог для него.

17_1.gif (2276 b)

Идентификатор для поля ввода имеет название "счет". Напишем функцию формирования:

//*******************************************

Процедура Сформировать() 
Перем Т; 
Перем Ит;
Перем Заголовок;
Перем Опер;

Если Счет.Выбран() = 0 Тогда
Предупреждение("Не указан счет!");
Возврат;
КонецЕсли;

Т = СоздатьОбъект("Таблица");
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ВыполнитьЗапрос(Дата1, Дата2, Счет,,,, "Проводка"); 
Заголовок = "Карточка счета: "+Счет;
Т.ВывестиСекцию("Секция_1"); 
Ит.ВыбратьПериоды();

Пока Ит.ПолучитьПериод() = 1 Цикл
Опер = Ит.Операция;
Т.ВывестиСекцию("Секция_2"); 
КонецЦикла;

Т.ТолькоПросмотр(1);
Т.Показать();
КонецПроцедуры

И таблицу:

17_2.gif (2945 b)

Результатом работы будет отчет о том, какие операции были проведены по данному счету.

17_3.gif (794 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.