Шаг 14 - Автоматический расчет

Если Вы заметили, то в Документе не производится автоматический расчет. И сумма не сохраняется. Это плохо. Для того, чтобы изменения происходили нам нужно изменить форму и модуль.

С начала код в модуле:

Процедура Расчет()
	Сумма=Количество*Цена;
КонецПроцедуры

Процедура ПриОткрытии()
	Форма.Цена.ВыполнятьФормулуТолькоПриИзменении(1);
	Форма.Количество.ВыполнятьФормулуТолькоПриИзменении(1);
	Форма.Сумма.ВыполнятьФормулуТолькоПриИзменении(1)
КонецПроцедуры

Процедура ПриЗаписи()
	Операция.СуммаОперации = Итог("Сумма");
КонецПроцедуры

Функция Расчет() будет производить расчет, как таковой. ПриОткрытии() - это стандартная функция, которая будет настраивать параметры формы, а ПриЗаписи() будет подводить итог сумм. Помните, мы устанавливали галочку. Вот теперь этот расчет нужно привязать к колонке, а делается это так:

14_1.gif (8088 b)

Выбирается на форме колонка, и вызываются ее свойства. На закладке Дополнительно устанавливаются свойства, которые и вызывают функцию. Изменение этой колонки приводит к вызову процедуры расчета. Теперь, если Вы запустите , то у Вас будет производиться расчет автоматически. Все хорошо, но только не плохо бы еще сделать шапочку с именем операции. С помощью инструмента Текст у Вас есть возможность производить редактирование текста.

14_2.gif (980 b)

Так вот давайте сделаем шапочку "поступление товарно-материальных ценностей".

14_3.gif (2417 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.